Support » Theme: Ribbon Lite » php +7 compatibility

  • Hello, I noticed that my site was much slower after changing my version of PHP 7.0 and 7.2, so I did a Theme compatibility test. Below is the theme compatible?

    Plugin Usad: PHP Compatibility Checker

    FILE: /home2/xxxxxxxx/public_html/wp-content/themes/ribbon/functions/widget-fblikebox.php
    ————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————–
    18 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————

    FILE: /home2/xxxxxxxx/public_html/wp-content/themes/ribbon/functions/widget-ad125.php
    —————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————-
    28 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————-

    FILE: /home2/xxxxxxxx/public_html/wp-content/themes/ribbon/functions/plugin-activation.php
    —————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————-
    4030 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    —————————————————————————-

    FILE: /home2/xxxxxxxx/public_html/wp-content/themes/ribbon/functions/widget-ad300.php
    —————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————–
    28 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————–

    FILE: /home2/xxxxxxxx/public_html/wp-content/themes/ribbon/functions/widget-tweets.php
    ——————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————
    23 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————————

    FILE: /home2/xxxxxxxx/public_html/wp-content/themes/ribbon/functions/widget-tabs.php
    ——————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————-
    61 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————————-

  • You must be logged in to reply to this topic.