Support » Plugin: Photo Gallery by Supsystic » PHP 7 Compatibility

  • Resolved brycef

    (@brycef)


    Hi we are testing for PHP 7 compatibility and the plugin yields these errors:

    FILE: /wp-content/plugins/gallery-by-supsystic/src/GridGallery/Optimization/Model/Encrypt.php
    ——————————————————————————————————————————————————
    FOUND 13 ERRORS AFFECTING 7 LINES
    ——————————————————————————————————————————————————
    14 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    14 | ERROR | Function mcrypt_get_iv_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    15 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    15 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
    15 | ERROR | The constant “MCRYPT_RAND” is deprecated since PHP 7.1 and removed since PHP 7.2
    16 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    16 | ERROR | Function mcrypt_encrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    29 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    29 | ERROR | Function mcrypt_get_iv_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    35 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    35 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    45 | ERROR | The constant “MCRYPT_RIJNDAEL_128” is deprecated since PHP 7.1 and removed since PHP 7.2
    48 | ERROR | The constant “MCRYPT_MODE_CBC” is deprecated since PHP 7.1 and removed since PHP 7.2
    ——————————————————————————————————————————————————

    FILE: /wp-content/plugins/gallery-by-supsystic/vendor/Twig/Lexer.php
    —————————————————————————————-
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————-
    87 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    91 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    —————————————————————————————-

    FILE: /wp-content/plugins/gallery-by-supsystic/vendor/Twig/Compiler.php
    ——————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————-
    218 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ——————————————————————————————-

    Can you help address these?

Viewing 1 replies (of 1 total)
  • Plugin Author supsystic

    (@supsysticcom)

    Hello, @brycef
    Thank you for your compatibility note.
    We will take them into account and will try to eliminate them in the next releases.

    Best regards,
    Ole

Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7 Compatibility’ is closed to new replies.