Support » Plugin: WP Email Template » PHP 7 Compatibility?

  • Resolved krishaamer

    (@krishaamer)


    Hello!

    I love the plugin, thanks for all the hard work! Unfortunately The WP Engine PHP Compatibility Checker says the plugin is not PHP 7 compatible. Are you working to fix this?

    FILE: /nas/content/live/esl2/wp-content/plugins/wp-email-template/admin/admin-interface.php
    -------------------------------------------------------------------------------------------
    FOUND 2 ERRORS AFFECTING 2 LINES
    -------------------------------------------------------------------------------------------
     402 | ERROR | Global with variable variables is not allowed since PHP 7.0
     441 | ERROR | Global with variable variables is not allowed since PHP 7.0
    -------------------------------------------------------------------------------------------
    
    FILE: /nas/content/live/esl2/wp-content/plugins/wp-email-template/includes/mandrill/Mandrill.php
    -------------------------------------------------------------------------------------------------------------
    FOUND 2 ERRORS AND 2 WARNINGS AFFECTING 4 LINES
    -------------------------------------------------------------------------------------------------------------
     127 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4.
     216 | WARNING | INI directive 'magic_quotes_runtime' is deprecated since PHP 5.3 and removed since PHP 5.4.
     295 | ERROR   | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
     301 | ERROR   | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    -------------------------------------------------------------------------------------------------------------
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7 Compatibility?’ is closed to new replies.