Support » Theme: Spacious » PHP 7 Compatability

  • Just an FYI for a future update:

    Using the WordPress Site Health tool issues the following warning:

    /themes/spacious-pro/inc/widgets/widgets.php
    Use of deprecated PHP4 style class constructor is not supported since PHP 7

    I have successfully updated to PHP version 7.3 but this warning may need to be addressed in future updates of the Spacious theme.

    Thanks.

Viewing 1 replies (of 1 total)
  • Hi,

    First of all, thank you for your confirm about this. However, we had already fixed that issue just before PHP 7 was released. So, if you have not updated the theme within your site then, can you upgrade to the latest version of the theme in your site and check once? Also, please ensure to create the site backup first before you update the theme for your site in case something may get broken for your site. Hope you have got it.

    Thanks.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.