Support » Plugin: Persian Woocommerce SMS » PHP 7 Compatibility issues

  • Hi there,

    There is some errors and warnings in PHP 7.1 compatibility test:

    FILE: ***/public_html/wp-content/plugins/persian-woocommerce-sms/includes/nusoap.php
    ----------------------------------------------------------------------------------------------------------------------------------
    FOUND 37 ERRORS AND 11 WARNINGS AFFECTING 40 LINES
    ----------------------------------------------------------------------------------------------------------------------------------
      225 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     1041 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     1134 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     2122 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     2214 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     2437 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
     2440 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4
     3631 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     3635 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3640 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3642 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3658 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3659 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3695 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3699 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3700 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3707 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3708 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3779 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3842 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     3844 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4419 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4439 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4439 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4440 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4441 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4442 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4442 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4442 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4443 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4443 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4508 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4514 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4514 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4515 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4516 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4517 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4518 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4518 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4518 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4519 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4519 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     4654 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     5339 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     5343 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     5344 | ERROR   | Global variable '$HTTP_SERVER_VARS' is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SERVER instead
     6577 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     7255 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ----------------------------------------------------------------------------------------------------------------------------------
    
    • This topic was modified 1 year, 4 months ago by  Amin.
    • This topic was modified 1 year, 4 months ago by  Amin.
  • The topic ‘PHP 7 Compatibility issues’ is closed to new replies.