Support » Plugin: NGG Smart Image Search » PHP 7 comapatibility

  • Resolved Carlos Revilla

    (@carlos-revilla)


    I want to switch to php 7 so I ran the PHP Compatibility Checker plugin and got this error:

    FILE: /home/elespiri/public_html/wp-content/plugins/ngg-smart-image-search/includes/class-ngg-smart-image-search-activator.php
    ———————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————-
    39 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
    ———————————————————————————-

    Carlos

Viewing 1 replies (of 1 total)
  • Plugin Author wpo-HR

    (@wpo-hr)

    Thanks for the info.
    I will have a look at this ambiguity for the next release.
    However, the plugin is tested and will work fine with PHP 7.0 (I am using it with PHP 7.0.16).
    Kind regards,
    Harald

Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7 comapatibility’ is closed to new replies.