Support » Plugin: NS Remove Related Products for WooCommerce » php 7.4 compatibility

  • tonygoodrich

    (@tonygoodrich)


    When (briefly) upgadeing to PHP 7.4 I got this error

    PHP Deprecated: Unparenthesized a ? b : c ? d : e is deprecated. Use either (a ? b : c) ? d : e or `a ? b : (c ? d : e)

Viewing 4 replies - 1 through 4 (of 4 total)
  • Same here

    Thread Starter tonygoodrich

    (@tonygoodrich)

    I have found a work round which involves either disabling with css or php which you can add via the code snippets plugin

    Plugin Author NsThemes

    (@nsthemes)

    Hello @tonygoodrich and @andrerabelo

    can you tell us, more about this issue please?
    What line of code and file name?

    Best regards

    Same issue and it’s just one line as I’ve manually patched it for a client.

    .../plugins/ns-remove-related-products-for-woocommerce/class/class-plugin-theme-review-request.php

    Line 332 in plugin version 2.3.5

    return ! isset( $code ) ? $triggers[ $group ] : isset( $triggers[ $group ]['triggers'][ $code ] ) ? $triggers[ $group ]['triggers'][ $code ] : false;

    • This reply was modified 7 months, 2 weeks ago by anon.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘php 7.4 compatibility’ is closed to new replies.