Support » Plugin: Yoast SEO » PHP 7.4.20 compatibility

  • Resolved insegnadelgiglio

    (@insegnadelgiglio)


    Hi, after updating to the plugin 1.6.6.1 version I’ve had an issue. It has been solved with a PHP downgrade from 7.4.20 to 7.3.28 version. Can you help me?
    This is the issue:
    Fatal error: Uncaught Error: Call to undefined function () in /home/customer/www/insegnadelgiglio.it/public_html/wp-content/plugins/wordpress-seo/src/integrations/watchers/indexable-post-type-archive-watcher.php:57 Stack trace: #0 /home/customer/www/insegnadelgiglio.it/public_html/wp-content/plugins/wordpress-seo/src/loader.php(201): Yoast\WP\SEO\Integrations\Watchers\Indexable_Post_Type_Archive_Watcher->register_hooks() #1 /home/customer/www/insegnadelgiglio.it/public_html/wp-includes/class-wp-hook.php(292): Yoast\WP\SEO\Loader->load_integrations('') #2 /home/customer/www/insegnadelgiglio.it/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array) #3 /home/customer/www/insegnadelgiglio.it/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #4 /home/customer/www/insegnadelgiglio.it/public_html/wp-settings.php(560): do_action('init') #5 /home/customer/www/insegnadelgiglio.it/public_html/wp-config.php(95): require_once('/home/customer/...') #6 /home/customer/www/insegnadelgiglio.it/ in /home/customer/www/insegnadelgiglio.it/public_html/wp-content/plugins/wordpress-seo/src/integrations/watchers/indexable-post-type-archive-watcher.php on line 57

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • after the update, even 16.6.1, also have loads of errors so much so cannot keep it on as it takes the live sites down and also still the pesky Yoast error
    Notice: Only variables should be assigned by reference in /home/tle/public_html/wp-content/plugins/wpseo-video/classes/class-wpseo-video-sitemap.php on line 843

    Plugin Support Maybellyne

    (@maybellyne)

    Hello,

    We are sorry about the error encountered after upgrading to Yoast SEO 16.6.1. Often, we see problems occur in combination with another plugin or theme. The fastest way to rule out any conflict, is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Twenty.

    Please test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin has a troubleshooting mode, which does not affect normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts

    If you do not feel comfortable doing this yourself or if this does not solve your issue, our Yoast SEO Premium plugin comes with one year of (technical) support.

    Plugin Support Maybellyne

    (@maybellyne)

    @tripledm

    We are sorry you’re having a similar issue. Please open a new request. That way it’s easier to track issues and provide assistance. Thanks!

    @maybellyne workign with big news publisher sites we cannot go hunting to resolve issues. the only solution thus far is rolling back to 16.5 for both free and paid yoast. We have even turned off all plugins accept Yoast free + premium on one publication and it still took the server down. They are also on php 7.4 for the record.

    • This reply was modified 2 months, 3 weeks ago by tripledm.
    Thread Starter insegnadelgiglio

    (@insegnadelgiglio)

    I solved in this way: I downgraded php to 7.3.28, updated the plugin to version 16.6.1, then re-enabled the php version 7.4.20. No issue.

    tried that as well but only lasted a few hours and the site was going down again lol.

    Thread Starter insegnadelgiglio

    (@insegnadelgiglio)

    @tripledm

    I’m sorry, but I don’t have the skills to give other suggestions.

    Having the same issue. After updating the plugin, I have been unable to create a new post.

    I get this rather cryptic message on a blank page ‘The editor has encountered an unexpected error.’ Unable to make a new page nor edit a page.

    Luckily, it was the only updated at that moment and I have several websites, so I was able to troubleshoot the issue fairly quickly.

    What I’ve found so far is that this is not theme related, as it’s happening on multiple sites I run.

    The only solution at this time is to roll back the update to 16.5. Sadly, it doesn’t really seem like the people making this plugin understand why this issue is happening, so this might become a a rather useless plugin going forward.

    @pinkerton84 Yoast is an awesome plugin and the premium version as well. The problem is there are a lot of dependencies especially with other plugins running as well so the potential for conflicts are huge.

    Your problem hoever relates to the block editor so check your php version, update Wodpress and all plugins and the theme. If they are up to date and you are on min php 7.4 then open a new thread here for yoast to be able to help.

    thanks for the input tripledm. I thought my php was up to date, but I just double checked and realized I’m running 7.3.28.

    I usually get a notification in my dashboard if php needs to be updated, so I’m perplexed as to why none of my websites alerted me to the php being out of date.

    Anyway, I’m gonna get that sorted in the morning and then see if that fixes the issue.

    thank you for taking the time to reply and help.

    Got things sorted with my php, but that has not helped. I still get the same issue. Seems that only way I can get things to run right is to rollback to version 16.5.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.