• Resolved Doug Nix

    (@macadk)


    I ran the WPEngine compatibility checker plugin on my installation. It found the following items that generated warnings in your plugin:

    FILE: /home/ms101admin/public_html/wp-content/plugins/tweet-old-post/vendor/facebook/graph-sdk/src/Facebook/PseudoRandomString/McryptPseudoRandomStringGenerator.php
    ——————————————————————————————————————————————————————–
    FOUND 3 ERRORS AFFECTING 1 LINE
    ——————————————————————————————————————————————————————–
    57 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
    57 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    57 | ERROR | The constant “MCRYPT_DEV_URANDOM” is deprecated since PHP 7.1 and removed since PHP 7.2
    ——————————————————————————————————————————————————————–

    I’m running WP V5.3.2 on an Apache 2.4.41, with PHP 7.2. Site is hosted at WHC.CA

    Are these warnings legitimate, and will they cause my site to crash if I run PHP 7.3?

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7.3 Compatibility’ is closed to new replies.