Support » Plugin: Broken Link Checker » PHP 7.3 compatibility

  • I am a web designer who installs your plugin on all my websites. Running PHP Compatibility plugin to upgrade my sites to PHP 7.3, I get the following result for Broken Link Checker. Please upgrade your code. Love the plugin!

    FILE: /home/atext/public_html/wp-content/plugins/broken-link-checker/includes/utility-class.php
    ————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————
    42 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————

    FILE: /home/atext/public_html/wp-content/plugins/broken-link-checker/core/core.php
    ———————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————–
    957 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ———————————————————————————————————–

    FILE: /home/atext/public_html/wp-content/plugins/broken-link-checker/modules/extras/plaintext-url-parser-base.php
    —————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————–
    82 | WARNING | The constant “FILTER_FLAG_HOST_REQUIRED” is deprecated since PHP 7.3
    —————————————————————————————————————–

    FILE: /home/atext/public_html/wp-content/plugins/broken-link-checker/modules/checkers/http.php
    ———————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————–
    147 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ———————————————————————————————————–

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same request and also love the plugin! Here are the three warnings I get:

    FILE: /public_html/wp-content/plugins/broken-link-checker/core/core.php
    —————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————
    957 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    —————————————————————————————

    FILE: /public_html/wp-content/plugins/broken-link-checker/modules/checkers/http.php
    —————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————
    147 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    —————————————————————————————

    FILE: /public_html/wp-content/plugins/broken-link-checker/includes/utility-class.php
    —————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————
    42 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    —————————————————————————————

    @almendron, so I’m not sure I understand. Are the functions going to be updated at some point in a new release or do we need to manually change the code in the files specified in the article?

    Thank you!

    @muzicutza81

    The next version is very likely to solve the problem. Meanwhile, you can apply the proposed code.

    @almendron, when is the next version scheduled to be released?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.