Support » Plugin: Arconix FAQ » PHP 7.3 Compatability

  • Is the plugin compatible w/ PHP 7.3? The PHP Compatability plugin displays the following warning/error for the plugin.

    Thank you for creating a great addition to the wordpress community ….. Rick

    FILE: /wp-content/plugins/arconix-faq/includes/class-arconix-faq-admin.php
    ————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————-
    649 | ERROR | “$this” can no longer be used in a plain function or method since PHP 7.1.
    ————————————————————————————————————————-

    FILE: /wp-content/plugins/arconix-faq/includes/metabox/includes/CMB2_Base.php
    ————————————————————————————————————————————————————————————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————————————————————————————————————————————————————————-
    417 | WARNING | Since PHP 7.0, functions inspecting arguments, like func_get_args(), no longer report the original value as passed to a parameter, but will instead provide the current value. The parameter “$message” was used, and possibly changed (by reference), on line 416.
    ————————————————————————————————————————————————————————————————————————————————————————————-

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • bump
    7.3?
    7.4?

    Plugin Support kenil802

    (@kenil802)

    Hi @rbarron,

    Extremely sorry for the delay in response.

    We have checked the compatibility of our Arconix FAQ plugin with the PHP version 7.3 and it is working fine on our site.

    So, could you please try again by clearing the cache and then check whether it is working fine or not.

    Please let us know how it goes.

    Regards,
    Kenil Shah

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7.3 Compatability’ is closed to new replies.