Support » Plugin: UpdraftPlus WordPress Backup Plugin » PHP 7.2 Warnings

  • Resolved Akira Leir

    (@akiraleir)


    Apparently nothing has stopped working, but these warnings keep popping up in the logs. Should I not worry about it or is this 7.2’s “feature” breaking something within the plugin that I haven’t experienced yet?

    PHP message: PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/www/wordpress/wp-content/plugins/updraftplus/class-updraftplus.php on line 1671

Viewing 4 replies - 1 through 4 (of 4 total)
  • Here another warning:

    [16-Sep-2017 07:11:36 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1448
    [16-Sep-2017 07:11:51 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1370
    [16-Sep-2017 07:11:51 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [16-Sep-2017 07:11:51 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [16-Sep-2017 07:11:51 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [17-Sep-2017 07:51:38 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1448
    [17-Sep-2017 07:52:01 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1370
    [17-Sep-2017 07:52:01 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [17-Sep-2017 07:52:01 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [17-Sep-2017 07:52:01 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [18-Sep-2017 07:40:47 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1448
    [18-Sep-2017 07:41:03 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1370
    [18-Sep-2017 07:41:03 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [18-Sep-2017 07:41:03 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    [18-Sep-2017 07:41:03 UTC] PHP Warning:  escapeshellarg() has been disabled for security reasons in /.../public_html/wp-content/plugins/updraftplus/class-updraftplus.php on line 1375
    Plugin Author David Anderson

    (@davidanderson)

    @iuriem That’s just PHP telling you that your hosting company has disabled some parts of the PHP language. UD can cope with that, so you can just ignore it.

    @akiraleir Thanks. I’ve adjusted the relevant code section so that the next release will not throw the message on PHP 7.2+.

    Unfortunately, the problem from @akiraleir still happens, but in another file this time. Since I switched to PHP 7.2 a few days ago, I’m getting this warning each time when Updraftplus makes a backup:

    [08-Dec-2017 07:10:02 UTC] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/vhosts/ibexy.cool/httpdocs/wp-content/plugins/updraftplus/backup.php on line 1432

    I just updated to 1.13.16, and I can confirm that the problem still happens.

    Thank you for making such a great plugin! 🙂

    Plugin Author David Anderson

    (@davidanderson)

    @doomlaur Thanks for the report. That’s already fixed in our development version. It’s only cosmetic – i.e. doesn’t affect activity.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP 7.2 Warnings’ is closed to new replies.