Support » Plugin: Wordfence Security - Firewall & Malware Scan » PHP 7.2 Warning – Wordfence 7.1.2

  • Resolved 77well88done99

    (@77well88done99)



    Hello,
    I have got PHP error_log on my site (PHP 7.2) after update Wordfence to version 7.1.2, i.e:

    PHP Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2349
    PHP Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2349
    PHP Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2349
    PHP Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2349
    PHP Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2349

    Use:
    WP 4.9.5
    WC 3.3.4

    Thanks for your help 🙂

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @77well88done99,

    Our developers are aware of this issue and the upcoming Wordfence update (7.1.3) will include a fix.

    This is most likely caused by another plugin (still unidentified) passing a null value for the user in the authenticate filter.

    Hi,
    Thank you for your reply @wfyann. Here with I can add some information about the plugins from wordpress.org on my site, which is used for the authenticate filter, ie:
    – WPS Hide Login – By WPServeur, NicolasKulka, tabrisrp
    – Google Authenticator – Two Factor Authentication (2FA) – By miniOrange

    Thanks for great support 🙂

    Hi @77well88done99,

    Thank you for the additional information! I passed it on to our development team.

    Hi,
    After update to Wordfence v. 7.1.3, it seems ok now, many thanks for your help 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP 7.2 Warning – Wordfence 7.1.2’ is closed to new replies.