Support » Plugin: XML Sitemap & Google News » PHP 7.2 Warning of XML Sitemap & Google News feeds

  • Resolved pathankp

    (@pathankp)



    First of all thanks for such a great plugin.
    I am planning to upgrade my PHP version to 7.2 from 5.6 while testing the plugin compatibility with PHP 7.2 I found these warnings:

    `FILE: /wp-content/plugins/xml-sitemap-feed/includes/class-xmlsitemapfeed-admin.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————————————
    752 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    784 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    —————————————————————————————————————It’s
    is this possible to fix this? Its urgent I maybe not able to wait for the next update of the plugin.

    Thank You.

    • This topic was modified 3 months ago by  pathankp.
Viewing 1 replies (of 1 total)
  • Plugin Author RavanH

    (@ravanh)

    Hi @pathankp the issue is know and adressed in the current development version, and will be in the next release. In the mean time you can safely upgrade to PHP 7.2 since this is only a warning and not an error. The plugin has been tested and will work correctly on PHP 7.2.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.