Support » Plugin: Post Snippets » PHP 7.2 incompatibility

  • Resolved lisota

    (@lisota)


    Post Snippets is using create_function, which has been deprecated in PHP 7.2. This quickly fills the debug log with thousands of the following entries

    PHP Deprecated: Function create_function() is deprecated in /wp-content/plugins/post-snippets/src/PostSnippets/Shortcode.php on line 76

    When will Post Snippets be updated to be fully compatible with PHP 7.2?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Just updated to PHP 7.2 and started seeing these as well.

    Thanks for reaching out, there will be an update fixing this real soon (within a few days).

    @archon810and @lisota
    we are almost done, would you be willing to test this new version?

    @davdebcom We use composer for plugins, plus I’m really busy right now, so I’ll take a pass this time. Hope you can find testers and release soon. We had to pause deprecated warning reporting to Sentry and logs, so I’m looking forward to the fix and getting those re-enabled.

    Any ETA on the release please?

    davdebcom

    (@davdebcom)

    Hi

    If you want to beta test, we have the fix on Github:
    https://github.com/davdebcom/post-snippets

    We will do some more testing and probably release the official version via the WordPress repository at the end of next week.

    Kind reagrds
    David

    archon810

    (@archon810)

    Hi,

    Any updates on this?

    davdebcom

    (@davdebcom)

    Sorry, it took a bit longer to get the version done… I just released 3.0.0 which also has PHP 7.2 compatibility and a new UI. If there is anything else, feel free to get in touch! You can also reach me at david -AT- postsnippets.com.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP 7.2 incompatibility’ is closed to new replies.