• Resolved Zach

    (@zachwtx)


    Hello! While scanning the plugins we use for compatibility with PHP 7.2 I found a file in this plugin which causes an error and it does not look like it is conditional to PHP environments which support that code:

    FILE: /nas/content/live/today/wp-content/plugins/feedzy-rss-feeds/vendor/codeinwp/themeisle-sdk/src/Modules/Dashboard_widget.php
    ——————————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————————–
    104 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    ——————————————————————————————————————————–

    I don’t see a place that this file is loaded as a dependency from composer or npm so I don’t know if there is an updated version available you could use. Could you please look into how to pass this function’s result to a variable and replace the function call with that variable?

    Thank you!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7.2 error in themeisle-sdk file’ is closed to new replies.