Support » Plugin: Query Monitor » PHP 7.2 conflict?

  • Resolved businessdirectoryplugin

    (@businessdirectoryplugin)


    Hi everyone!

    I ran WPEngine’s PHP Compatibility Checker on PHP 7.2 and it’s flagging your plugin for 3 fatal errors:

    Can you please confirm if they are real issues or not?

    FILE: /…/wp-content/plugins/query-monitor/wp-content/db.php
    ————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————
    123 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ————————————————————————————————————

    FILE: /…/wp-content/plugins/query-monitor/collectors/environment.php
    ————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ————————————————————————————————————
    123 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    128 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ————————————————————————————————————

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.