Support » Plugin: Real Time Validation for Gravity Forms » PHP 7.2 compatible

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Amritansh Trivedi

    (@amritanshatwisetr)

    Hi @phj123,

    We are testing real-time validation over php 7.2 and soon release a version with official compatibility.
    Also, till now we have not found any such bugs on the latest php version, if you find any then please report here.

    Thanks.

    Great news, yes after updating to 7.2 I get this error in my console and the validation stops working:

    Uncaught SyntaxError: Unexpected roken <

    var jqr = jQuery; var f3 = new LiveValidation(“input_11_3″,jqr.extend({validMessage: ” “, jqObj: jqr,fieldType:”text” },additional_data )); all_validations[11][3] = f3; f3.add(Validate.Presence,{ failureMessage: “This field is required.”,validMessage: ” ” ,jqObj: jqr });<br />

    Please let me know if you could replicate the issue and when you update to full php 7.2 support.

    Really like your plugin can i donate maybe send me your paypal and i will send coffee.. 🙂

    • This reply was modified 1 year, 6 months ago by  phj123.
    Plugin Author Amritansh Trivedi

    (@amritanshatwisetr)

    Hi,

    I am not be able to replicate this issue on my end.
    Could you provide us little more detail about the issue & provide a form export.

    Thanks.

    Is there an email address so I can zip the form export and send it over?

    Thank you 🙂

    Plugin Author Amritansh Trivedi

    (@amritanshatwisetr)

    Hi,

    You can mail us at support@wisetr.com.

    Thanks.

    It is because of error, since $field[‘inputs’] contains a void.

    Can you change this in the next update so it is php 7.2.4 compatible?

    Change:

    real-time-validation-for-gravity-forms/public/class-gravity-forms-live-validation.php:176

    before: if ($field[‘type’] == “email” && count($field[‘inputs’]) > 1) {

    after: if ($field[‘type’] == “email” && !empty($field[‘inputs’]) && count($field[‘inputs’]) > 1) {

    Plugin Author Amritansh Trivedi

    (@amritanshatwisetr)

    Hi @phj123,

    Yes, we just pushed an update with the PHP 7.2 compatibilities.
    Just update and test once.

    Thanks for taking the keen interest in making the plugin better.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP 7.2 compatible’ is closed to new replies.