Support » Plugin: WP Security Audit Log » PHP 7.2 Compatibility Still Failing

  • Resolved Matt Ryan

    (@rynonet)


    The plugin is still reporting an error when running the PHP Compatibility Checker plugin used by a few major hosting companies (LiquidWeb and WPEngine to name a couple). If the plugin is truly compatible, can you request your plugin be added to the [compatibility checker whitelist](https://github.com/wpengine/phpcompat/wiki/Results) of safe plugins.

    Report from today:
    FILE: /home/s1/html/wp-content/plugins/wp-security-audit-log/classes/Connector/wp-db-custom.php
    ————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ————————————————————————————————————
    193 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    195 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ————————————————————————————————————

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor robertabela

    (@robert681)

    Hello @rynonet,

    Thank you for reaching out and for pointing it out.

    Please note that the plugin at the moment still runs on a PHP 7.2 install, even with these warnings. However we will be addressing these warnings in the next update, which we are releasing in a few days. So stay tuned to this page for further updates.

    Matt Ryan

    (@rynonet)

    :thumbsup:

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.