Support » Plugin: Link Fixer » php 7.2 compatibility issues

  • I need an updated version of php for another plugin I use. In preparation for that I ran the php compatibility checker. I receive two errors for permalink finder…

    625 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    685 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead

    Any ideas? Thanks for any help you can offer.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Keith P. Graham

    (@kpgraham)

    It’s time. I will get to it right away.

    Keith

    Thread Starter homebrewfinds

    (@homebrewfinds)

    Awesome… Thank you Keith!!

    Plugin Author Keith P. Graham

    (@kpgraham)

    Hey, it was already fixed.
    There used to be a method called mysql_escape. I wrote my own version when I converted over to mysqli and named it mysql_escape_mimic. Your compatibility tester was lazy and just looked for the mysql_ string in the code.
    I renamed the function so that the tester will ignore it.
    You can install the old version safely. I am updating the WordPress version to have the renamed function so it should show up in your updates as soon as I test it.

    Keith

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘php 7.2 compatibility issues’ is closed to new replies.