Support » Plugin: WordPress REST API (Version 2) » PHP 7.2 compatibility errors on rest-api plugin, Please fix

  • Can you please fix the error on this plugin, We are using this plugin in our website on PHP 7.2 version, We have checked the compatibility of rest api plugin with php 7.2? I’m receiving this error report on a PHP 7.2 compatibility test:

    FILE: /nas/content/live/devreplicon1/wp-content/plugins/rest-api/lib/endpoints/class-wp-rest-posts-controller.php
    —————————————————————————————————————–
    FOUND 2 ERRORS AFFECTING 2 LINES
    —————————————————————————————————————–
    773 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    782 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    —————————————————————————————————————–

    FILE: /nas/content/live/devreplicon1/wp-content/plugins/rest-api/lib/endpoints/class-wp-rest-revisions-controller.php
    ———————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ———————————————————————————————————————
    285 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    288 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ———————————————————————————————————————

    FILE: /nas/content/live/devreplicon1/wp-content/plugins/rest-api/lib/endpoints/class-wp-rest-comments-controller.php
    ——————————————————————————————————————–
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————————————————————————————————–
    588 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    589 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ——————————————————————————————————————–

    FILE: /nas/content/live/devreplicon1/wp-content/plugins/rest-api/extras.php
    ————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————
    150 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ———————————————————

    • This topic was modified 1 year, 1 month ago by sachintonte.
  • The topic ‘PHP 7.2 compatibility errors on rest-api plugin, Please fix’ is closed to new replies.