Support » Plugin: Advanced Cron Manager - debug & control » php 7.2 compatibility errors

  • Resolved eileenjst

    (@eileenjst)


    In using the plugin PHP Compatibility Checker to uncover php errors before switching to php 7.2, the Adv. Cron Manager gave these PHP 7.2 compatibility errors:

    FILE: /public_html/wp-content/plugins/advanced-cron-manager/inc/Cron/Object/Schedule.php
    —————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————
    7 | ERROR | ‘object’ is a soft reserved keyword as of PHP version 7.0 and a reserved keyword as of PHP version 7.2 and should not be used to name a class, interface or trait or as part of a namespace (T_NAMESPACE)
    ———————————————————————————————————————————————————————————————————————–

    FILE: //public_html/wp-content/plugins/advanced-cron-manager/inc/Cron/Object/Event.php
    ————
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————
    7 | ERROR | ‘object’ is a soft reserved keyword as of PHP version 7.0 and a reserved keyword as of PHP version 7.2 and should not be used to name a class, interface or trait or as part of a namespace (T_NAMESPACE)
    ———————————————————————————-

    Will these errors affect the use of the plugin? Will they be changed in the near future to remove the errors? Or, I can remove them somehow?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Kuba Mikita

    (@kubitomakita)

    Hi, thank you very much for the notice. This will be a subject of the next update, I wouldn’t advise updating PHP at the moment as most likely will break with a Fatal Error.

    Next version should be released tomorrow.

    Plugin Author Kuba Mikita

    (@kubitomakita)

    Hi @eileenjst, the new version has been just released and it’s compatible with PHP 7.2. Thanks for your patience!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘php 7.2 compatibility errors’ is closed to new replies.