Support » Plugin: Revive Old Posts - Auto Post to Social Media » PHP 7.2 compatibility

  • Resolved abrightclearweb

    (@abrightclearweb)


    I’ve tested this plugin for PHP 7 compatibility with the PHP Compatibility Checker plugin and get these errors:

    /wp-content/plugins/tweet-old-post/vendor/facebook/graph-sdk/src/Facebook/PseudoRandomString/McryptPseudoRandomStringGenerator.php
    ———————————————————————————————————————————————————————–
    FOUND 3 ERRORS AFFECTING 1 LINE
    ———————————————————————————————————————————————————————–
    57 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    57 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
    57 | ERROR | The constant “MCRYPT_DEV_URANDOM” is deprecated since PHP 7.1 and removed since PHP 7.2
    ———————————————————————————————————————————————————————–

    Will these be addressed in a future release?

Viewing 1 replies (of 1 total)
  • Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    Hi there, this is a false positive. Facebook has already told us and showed that they do have compatibility but that plugin has not been updated to reflect the changes.

    Or plugin works perfectly fine on PHP 7.2

Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7.2 compatibility’ is closed to new replies.