Support » Plugin: Google Reviews Widget » PHP 7.2 Compatibility

  • Resolved webheadcoder

    (@webheadllc)


    Hi,

    I ran the PHP 7 Compatibility plugin and it found the warnings below. Do you think you could update the plugin for PHP 7?

    widget-google-reviews/api/urlopen.php
    75 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4

    widget-google-reviews/api/json.php
    74 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author richplugins

    (@richplugins)

    Hi,

    The plugin is absolutely compatible with PHP 7 and by the way, we are using PHP 7 on the demo site http://demo.richplugins.com/

    The codes from warnings are not using under PHP 7, but it’s needed for compatible the old versions of PHP (< 5.0) which is sometimes found in users and without this code, the plugin will not work.

    The problem is that the plugin which you’re using to test compatibility with PHP 7 cannot understand that this code is not used under PHP 7 or greater. The compatibility plugin just search some keywords which deprecated in the latest version PHP and show warnings about it (without understanding that it’s not used).

    Thanks!

    • This reply was modified 8 months ago by  richplugins.
    • This reply was modified 8 months ago by  richplugins.
    • This reply was modified 8 months ago by  richplugins.
    • This reply was modified 8 months ago by  richplugins.
    webheadcoder

    (@webheadllc)

    ok, great! thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7.2 Compatibility’ is closed to new replies.