Support » Plugin: WordPress Ultra Simple Paypal Shopping Cart » php 7.2 compatibility

  • sylvia222

    (@sylvia222)


    First of all – love the plugin, thanks! I have been using it on a couple of sites. Unfortunately on one site it stopped working and I’m getting messages like these:

    Warning: session_start(): Cannot start session when headers already sent in /home/xxxxx/public_html/wp-content/plugins/wp-ultra-simple-paypal-shopping-cart/wp_ultra_simple_shopping_cart.php on line 29

    Notice: Undefined variable: post in /home/xxxxx/public_html/wp-content/plugins/wp-ultra-simple-paypal-shopping-cart/wp_ultra_simple_shopping_cart.php on line 104

    Notice: Trying to get property ‘ID’ of non-object in /home/xxxxx/public_html/wp-content/plugins/wp-ultra-simple-paypal-shopping-cart/wp_ultra_simple_shopping_cart.php on line 104

    The host recently updated php to 7.2 so I was wondering if it has anything to do wiht it. I’m also getting errors with other plugin that also uses paypal. Both plugins are used on another site I have with different host and they both work fine on php.5.6.38

    Another strange thing is that I deleted the plugin folder using ftp (I was hoping to reinstall it and keep the settings), but the error messages still come up, and plugin still appears sometimes in Admin, even though it’s not there.

    I’m not a developer, so I’m just trying to guess any correlation. Any help would be greatly appreciated. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • sylvia222

    (@sylvia222)

    Hi again,
    I switched from php 5.6.38 to 7.2 on the other website (where the plugin worked fine) and the same thing happened – I started getting error messages. So I reverted back.
    Unfortunately the host of the website I’m trying to fix right now doesn’t give me the option, they only use php 7.2

    Plugin Author Mike Castro Demaria

    (@mikecastrodemaria)

    I tested up to 7.0, and have no problem, but not with 7.2. I’ll do it asap and see if there is any evolution to do. Thanks, Mike

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘php 7.2 compatibility’ is closed to new replies.