Support » Plugin: Shield Security for WordPress » PHP 7.2 compatibility

  • Resolved newwper3

    (@newwper3)


    Hi,

    May I know does Shield compatibility with PHP 7.2 ?

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Paul

    (@paultgoodchild)

    This should not be a problem. The higher the better. If you do spot any issues, please report them and we’ll investigate

    newwper3

    (@newwper3)

    Hi,

    PHP Compatibility Checker found 3 errors and 37 Warnings
    Does it cause any problem?

    Thanks

    <em>FILE: /wp-content/plugins/wp-simple-firewall/src/common/googleauthenticator/googleauthenticator.php
    --------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 3 ERRORS AFFECTING 1 LINE
    --------------------------------------------------------------------------------------------------------------------------------------------------------------
     37 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     37 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
     37 | ERROR | The constant "MCRYPT_DEV_URANDOM" is deprecated since PHP 7.1 and removed since PHP 7.2
    --------------------------------------------------------------------------------------------------------------------------------------------------------------
    Plugin Author Paul

    (@paultgoodchild)

    This is fine. What your tool is highlighting is “fallback” code for folk that don’t have php7+

    https://wordpress.org/support/topic/php-7-1-compatibility-7/

    I use it with php 7.2 that’s one of the rare plugin with so much features that doesn’t throw warnings. You can run it without any problems.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.