Support » Plugin: Frontend Checklist » PHP 7.2 compatability issue

  • Resolved adamrafferty

    (@adamrafferty)


    HI!

    I have hosting on WPEngine and my tech guy ran a PHP 7.2 test.

    Your plugin came up as showing ERROR, so I’ll either have to stop using it,
    (which would be a pity since I am very happy with it) or get an update from your team that makes in PHP 7.2 compliant.

    I use the plugin on locked membership pages, it is functioning fine on whatever {HP is running now, but 7.2 may be a problem.

    Please let me know what to do next.

    Thank you!

    Adam Rafferty

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author JonasBreuer

    (@jonasbreuer)

    Hi Adam,

    Thank you for pointing this out to me. I didn’t run into any errors when testing the plugin with PHP 7.2. Could you provide further information what the error is about?

    Cheers,
    Jonas

    Here is the error my tech guy found:

    Name: Frontend Checklist
    
    FILE: /nas/content/live/studywithadam/wp-content/plugins/frontend-checklist/fpdf/font/unifont/ttfonts.php
    ---------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------------------------
     72 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ---------------------------------------------------------------------------------------------------------
    Plugin Author JonasBreuer

    (@jonasbreuer)

    Thank you. I’ll look into that and publish a fix until the end of the month.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7.2 compatability issue’ is closed to new replies.