• Resolved dav74

    (@dav74)


    Hello,

    Does your plugin work with PHP Version PHP 7.2.17 ?

    After pushing PHP 7.2 to our site, we had some incorrect data come through on the “Audience” section of Google analytics. Basically we were showing virtually no traffic in the Audience overview for a period of about 4-5 hrs, even though there were visitors continually on the site.

    Would be great if you can let me know your thoughts…. thank you…

    PS – I switched back to PHP 7.1 and the Audeince view in Google analytics is displaying correctly again. Maybe just a coincidence?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,
    A quick reply would be appreicated 🙂

    Plugin Support Michael

    (@mikkamp)

    Automattic Happiness Engineer

    Hi there,

    I have the WooCommerce Google Analytics Integration plugin running on PHP 7.2.17, on a test site without any issues. I just checked traffic in the Audience Overview and I’m seeing users appear there.

    I’d suggest to have a look at any PHP log files to see if any specific warnings / errors are showing up.

    Otherwise you could configure your site to log warnings / errors to a file like is suggested here: https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging
    You can then check the log file to see if any additional clues show up about code which might not be compatible.

    Thanks for the advise @mikkamp

    There are no php errors in the log file, but I suspect maybe it was a day where Google was having some issues. I will switch back to PHP 7.2 and check again Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.