Support » Plugin: All-in-One Event Calendar » PHP 7.2

  • Resolved happygojira

    (@happygojira)


    We just update all our sites to php 7.2 and have this error on several of them: “CSS compilation failed because you don’t have enough free memory (a minimum of 24M is needed).”

    We’ve updated the memory limit to 256m but still get this error.
    On some sites, the calendar displays properly but still has the warning and on the main site the calendar does not display properly.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @happygojira,

    PHP 7.2 uses vastly more memory than previous versions and some users have solved this problem by switching down to PHP 7.0.

    Otherwise, I suggest increasing the memory limit, and try the feed refresh again — it should finish, then produce a confirmation or error message — this is how you know it finishes.

    There are 3 ways to increase your PHP memory limit:

    1. Add this to wp-config file:

    define(‘WP_MEMORY_LIMIT’, ‘500M’);

    or

    2. Edit your PHP.ini file (requires access to your server files).
    If you have access to your PHP.ini file, change the line in PHP.ini.
    If your line shows 64M, try 500M:

    memory_limit = 500M

    or

    3. Edit your .htaccess file
    If you don’t have access to PHP.ini try adding this to an .htaccess file:

    php_value memory_limit 500M

    Thanks, we will give it a try and let you know.
    Cheers.

    Have the same problem. Don’t have access to php.ini file so tried option #3, editing the .htaccess file. This resulted in corrupting my website formatting. Removed the line. Everything back to normal. So then tried option #1. Result: No change, got the warning that CSS compilation failed. Why is it that it only fails with your plugin?

    BTW, my host requires us to use PHP 7.2, so going back to 7.0 is not an option.

    • This reply was modified 5 months, 1 week ago by  jennal.

    Hello, yes I am having the same issue.

    I have tried steps 1 + 3 above. As well as completely reinstalling the plugin as recommended in this thread

    https://wordpress.org/support/topic/php-7-2-28/

    No luck yet. Any suggestions?

    Thanks, Malcolm

    • This reply was modified 5 months, 1 week ago by  MalMac.

    @malmac
    @jennal

    Your options are to either increase the memory to a higher amount until the error goes away (depends on your hosting), or, downgrade your PHP version to 7.0 which uses less memory.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.