Support » Plugin: Better Search Replace » PHP 7.2

  • integratingawareness

    (@integratingawareness)


    When I run a PHP 7.2 compatibility test for Better Search Replace, I get a Warning message; “WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4”. Will the plugin be updated soon to avoid this problem?

Viewing 2 replies - 1 through 2 (of 2 total)
  • roam92

    (@roam92)

    I ran the PHP version compatibility checker and got the same message. So I’m trying to figure out if this is a real problem or not.

    First thing, notice it is a Warning and not an Error. So that’s a good start.

    Here is the line of code that the checker flagged:

    $return .= ‘Safe Mode: ‘ . ( ini_get( ‘safe_mode’ ) ? ‘Enabled’ : ‘Disabled’ . “\n” );

    According to the warning message, the ‘safe_mode’ feature was deprecated in PHP 5.3 and completely REMOVED as of PHP 5.4…

    So this does not appear to be a new issue. In fact, it would still seem to be the case when running this same plugin under PHP 5.5 or PHP 5.6.

    In other words, not being new behavior for any migration to PHP 7, it doesn’t really seem to me to be a true problem.

    Disclaimer: I have no connection to the plugin or its author(s). Hope this helps nevertheless.

    I’ve seen the same thing. I opened a support ticket on their website. Hopefully I’ll hear back.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7.2’ is closed to new replies.