Support » Plugin: XML Sitemap & Google News » php 7.1 warning

  • Resolved joneiseman

    (@joneiseman)


    I see the following warning in my php_errorlog file
    [18-Mar-2018 19:12:12 UTC] PHP Warning: strtolower() expects parameter 1 to be string, array given in /home/class211/public_html/wp-includes/formatting.php on line 1905

    This warning occurs due to the following call on line 1215 of xml-sitemap-feed/include/class-xmlsitemapfeed.php:
    get_lastpostdate(‘gmt’, $news_post_type)

    Apparently $news_post_type is not a string.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • The $news_post_type variable is an empty array and this results in the Warning message.

    Plugin Author RavanH

    (@ravanh)

    Hi @joneiseman thanks for reporting. I’ll take a look at this right away…

    Plugin Author RavanH

    (@ravanh)

    Please try the newly released version 4.8.1 🙂

    Hello Ravan,

    i still get this error after update to 4.8.1:

    Warning: strtolower() expects parameter 1 to be string, array given in /homepages/21/d724483918/htdocs/clickandbuilds/starsontv/wp-includes/formatting.php on line 1902

    I downgrade to 4.7.5.

    Do you know what the problem here is?

    Greetings Sebi

    It’s showing I already have the latest version of the plugin. I don’t see version 4.8.1.

    Plugin Author RavanH

    (@ravanh)

    sorry, in my haste to update, it seems something went wrong… 4.8.2 is now out.

    Plugin Author RavanH

    (@ravanh)

    Visit your Dashboard > Updates page and use the button “Check Again” at the top there…

    I installed the new version and (so far) no more warnings.

    I installed 4.8.2 and there are no more warnings. Thank you very much 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘php 7.1 warning’ is closed to new replies.