Support » Plugin: Imsanity » PHP 7.1 or earlier error

  • Resolved childsview

    (@childsview)


    When I run the plugin to check PHP compatibility, I get the following error:

    FILE: /home/users/***/wp-content/plugins/imsanity/imsanity.php
    ———————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————-
    222 | ERROR | The function imagecreatefrombmp() is not present in PHP version 7.1 or earlier
    ———————————————————————————————-

    Would you eliminate this error?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    It’s not actually an error, because the plugin comes with it’s own copy of imagecreatefrombmp() for versions 7.1 and earlier. You can pretty much use it on any version of PHP, though I would recommend getting your site on 7.1 or better soon, as anything older is no longer supported by the PHP team (and I don’t test it on old versions of PHP either).

    Thread Starter childsview

    (@childsview)

    Thank you fo reply.
    OK. I think I understood well.
    I’m always grateful for your contribution.

    @nosilver4u, I manage a few dozen sites, many of which use Imsanity, on the Siteground platform – I’m receiving PHP 7.1 notifications from their system often, and usually only Imsanity is the listed plugin that is “Failed to Update”. Is there anything that can be done to squelched that mass-notification for all sites affected?

    Steve

    Plugin Author nosilver4u

    (@nosilver4u)

    @3cstudio That sounds like an entirely different issue, please start a separate thread (if you have not done so already).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP 7.1 or earlier error’ is closed to new replies.