Support » Plugin: TablePress » PHP 7.1 incompatibility?

  • Hey.

    I just ran a PHP compatibility check for PHP 7.1 on a site I manage. It came back with two errors. The plugin clearly states however that it can’t detect backwards compatibility, which ofc means that this might not be a problem at all, but they aren’t listing TablePress in their whitelist, so I figured I’d at least give you this report. If it is indeed not an issue, perhaps it’d be a good idea to submit it to the github wiki for whitelisting: https://github.com/wpengine/phpcompat/wiki/Results

    `FILE: …/wp-content/plugins/tablepress/views/view-about.php
    FOUND 2 ERRORS AFFECTING 2 LINES

    185 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    186 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ———————————————————————————–

    FILE: …/wp-content/plugins/tablepress/libraries/excel-reader.class.php
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES

    222 | WARNING | Method name “OLERead::__readData” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    240 | WARNING | Method name “OLERead::__readPropertySets” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ———————————————————————————-

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7.1 incompatibility?’ is closed to new replies.