Support » Plugin: Cerber Security, Antispam & Malware Scan » PHP 7.1 & 7.2 compatible?

  • Resolved catmaniax

    (@catmaniax)


    Hello!

    I ran the php compatibility checker plugin and it showed the 2 errors below in its report for Cerber:

    FILE: /………./www/wp-content/plugins/wp-cerber/wp-cerber.php
    ——————————–
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————–

    4590 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    4612 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead

    So, can they be safely ignored? Does the plugin work properly on PHP 7.1 and 7.2?

    Please let me know.
    Thanks!

    • This topic was modified 2 years, 1 month ago by catmaniax.
Viewing 3 replies - 1 through 3 (of 3 total)
  • I have php 7.2 and i have no problem with this plugin

    Plugin Author Gioni

    (@gioni)

    Hi! Absolutely compatible and tested, you can ignore them. Those routines are used on versions of PHP older than 7.0. Sorry but your “php compatibility checker” is a bit naive to check modern solutions like WP Cerber. 🙂

    Thanks for the reply.

    Would you know any other more reliable plugin to test PHP compatibility because I’m in the process of upgrading…?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7.1 & 7.2 compatible?’ is closed to new replies.