Support » Plugin: ManageWP Worker » PHP 7.1 compatibility

  • Resolved gleenk

    (@gleenk)


    Hi guys, is it possibile to make plugin works with php 7.1? After a test i got this result:

    
    FILE: wp-content/plugins/worker/src/PHPSecLib/Crypt/Random.php
    ---------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
    ---------------------------------------------------------------------------------------------------------------------------------
      75 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      75 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
     114 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     114 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
    ---------------------------------------------------------------------------------------------------------------------------------
    
    FILE: wp-content/plugins/worker/src/PHPSecLib/Crypt/Base.php
    ----------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 33 WARNINGS AFFECTING 17 LINES
    ----------------------------------------------------------------------------------------------------------------------------------
      454 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      454 | WARNING | Function mcrypt_list_algorithms() is deprecated since PHP 7.1; use OpenSSL instead
      671 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      671 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
      704 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      704 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
      707 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      707 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      712 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      712 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      721 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      721 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      735 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      735 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      738 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      738 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
      903 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      903 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
      931 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      931 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      936 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      936 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      951 | WARNING | Function mdecrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
      954 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
      954 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
     1320 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     1320 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; use OpenSSL instead
     1321 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     1321 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; use OpenSSL instead
     1327 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     1327 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; use OpenSSL instead
     1332 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     1332 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    ----------------------------------------------------------------------------------------------------------------------------------
    
    FILE: wp-content/plugins/worker/src/PHPSecLib/Crypt/Rijndael.php
    ---------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 8 WARNINGS AFFECTING 4 LINES
    ---------------------------------------------------------------------------------------------------------------------------------
     811 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     811 | WARNING | Function mcrypt_list_algorithms() is deprecated since PHP 7.1; use OpenSSL instead
     830 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     830 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; use OpenSSL instead
     831 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     831 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; use OpenSSL instead
     836 | WARNING | Extension 'mcrypt' is deprecated since PHP 7.1 - use openssl (preferred) or pecl/mcrypt once available instead.
     836 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; use OpenSSL instead
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support shteffk

    (@shteffk)

    Hey there,

    Thanks for reaching out to us.

    No need to worry, Worker plugin is compatible with 7.1 and newer versions of PHP.

    The warnings you receive are there because we try to maintain compatibility with older versions of PHP with a single plugin.

    When we detect that you are using PHP 7 or newer, parts of the code are used for 5.x versions of PHP are not active.

    This also allows you to switch between the PHP versions without having to worry about ManageWP functionality.

    Let me know if you have any questions.

    Kind regards,

    Ty, I’ll do an upgrade so.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7.1 compatibility’ is closed to new replies.