Support » Plugin: Relevanssi - A Better Search » PHP 7.0 Error help

  • Resolved YoWangdu

    (@yowangdu)


    I am trying to move to php 3 my site. I am getting php 7 error.Can you someone help about this issue?
    12 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.

    Thank you,

    Lobsang

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Disregard the error, Relevanssi doesn’t use the mysql_ interface anywhere. Relevanssi does all database work through the $wpdb interface.

    Older versions of Relevanssi include the cache functions, which use the mysql_ functions. That’s probably why it’s complaining. You should update Relevanssi to the latest version (for many reasons, including serious security issues), and then that problem will be sorted as well.

    If the error is blocking things, just delete /wp-content/plugins/relevanssi/lib/cache.php.

    Hi Mikko,

    Thanks I updated on my staging and it seems work fine on my staging site. Great plugin!!!!!!

    Lobsang

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7.0 Error help’ is closed to new replies.