Support » Plugin: Gravity Forms Constant Contact » Php 7.0 compatibility error

  • Resolved ichibanj

    (@ichibanj)


    Hi there – just scanned this using the WP Engine compatibility checker plugin and got this error – is it possible to fix this please?
    Many thanks 🙂

    FILE: /nas/content/live/xxxxxxxxxxxx/wp-content/plugins/gravity-forms-constant-contact/api/cc_class.php
    —————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 1 LINE
    —————————————————————————————————————
    82 | ERROR | Function eregi() is deprecated since PHP 5.3 and removed since PHP 7.0; Use preg_match() instead
    82 | ERROR | Extension ‘ereg’ is deprecated since PHP 5.3 and removed since PHP 7.0; Use pcre instead
    —————————————————————————————————————

    FILE: /nas/content/live/xxxxxxxxxxxx/wp-content/plugins/gravity-forms-constant-contact/constantcontact.php
    ——————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————–
    1295 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————————————————–

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Php 7.0 compatibility error’ is closed to new replies.