Support » Plugin: BackWPup - WordPress Backup Plugin » PHP 7.0 compatibility?

  • I’m wanting to update my servers to PHP 7.0 and want to know which plugins are compatible.

    Using the plugin from WP Engine: PHP Compatibility Checker, I get 33 errors for BackWPup 3.3.4.

    INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    Bitwise shifts by negative number will throw an ArithmeticError in PHP 7.0
    INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ‘resource’ is a reserved keyword as of PHP version 7.0 and cannot be used to name a class, interface or trait or as part of a namespace (T_NAMESPACE)
    Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0

    Would the plugin developers want the full error log?

    I’ve read comments saying the checker is not accurate – so I’m asking for feedback.

    regards Jason

Viewing 4 replies - 1 through 4 (of 4 total)
  • I haven’t run a compatibility check but I’m running BackWPup 3.3.4 on WP 4.7 and PHP 7.0 without any problems.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    I”m running backwpup on over 20 sites running php 7 without issues.

    Thanks guys.

    If PHP Compatibility Checker hasn’t got the false positive – checking right, they should add BackWPup to the whitelist.

    All seems to work just fine on my sites that have just been migrated to a new server with PHP 7 and all latest versions of WP and plugins. But I came here to check compatibility with the plugin creators after noticing teh many warnings given by the PHP compatibility checker plugin.

    Here are teh warnings I get, just in ncase these are useful for the developers (apologies for horiible formatting – pasted straight from the plugins output):

    [Large code excerpt removed by moderator per forum rules. Please use Pastebin or a Gist for all large code or text excerpts.]

    Text available here: http://pastebin.com/S6XHmHMj

    • This reply was modified 1 year, 9 months ago by  bdbrown.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP 7.0 compatibility?’ is closed to new replies.