Support » Plugin: Swift Performance Lite » PHP 7.0 compatibility

  • Resolved outpacer

    (@outpacer)


    After PHP compatibility test with PHP Compatibility Checker WordPress plugin, I got following errors below. How to fix them so I could update my PHP version? Thank you

    FILE: /wp-content/plugins/swift-performance-lite/includes/setup/setup.php
    —————————————————————————————————————————
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    —————————————————————————————————————————
    294 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    398 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    —————————————————————————————————————————

    FILE: /wp-content/plugins/swift-performance-lite/includes/cache-status/cache-status.php
    —————————————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————————————–
    74 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    —————————————————————————————————————————————–

    FILE: /wp-content/plugins/swift-performance-lite/performance.php
    ——————————————————————————————————————
    FOUND 4 ERRORS AFFECTING 4 LINES
    ——————————————————————————————————————
    600 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    726 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    2048 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    2068 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ——————————————————————————————————————

    FILE: /wp-content/plugins/swift-performance-lite/modules/cache/cache.php
    ————————————————————————————————————————–
    FOUND 5 ERRORS AFFECTING 5 LINES
    ————————————————————————————————————————–
    272 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    312 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    758 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    829 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    1060 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ————————————————————————————————————————–

    FILE: /wp-content/plugins/swift-performance-lite/modules/image-optimizer/image-optimizer.php
    ———————————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————————————-
    685 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ———————————————————————————————————————————————-

    FILE:/wp-content/plugins/swift-performance-lite/modules/asset-manager/asset-manager.php
    ——————————————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————————————————————————————————————————
    163 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    180 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Fred

    (@fredawd)

    The mysql is false positive, we are using an own function for some queries: Swift_Performance::mysql_query

    Thank you for a quick reply, Fred.
    Probably the main my question is whether I can use your plugin with PHP 7.0 and do not worry, that I will get issues because of compatibility?

    Thanks

    Plugin Contributor Fred

    (@fredawd)

    Swift is fully compatible with PHP 7.X

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7.0 compatibility’ is closed to new replies.