Support » Plugin: LiteSpeed Cache » PHP 7.0 compatibility

  • Resolved benz1

    (@benz1)


    PHP Compatibility Checker is reporting an error for Easy Facebook Likebox as follows when checked for PHP 7.0 compatibility:

    FILE: /home/onecom/public_html/wp-content/plugins/litespeed-cache/lib/litespeed/litespeed-crawler.class.php
    -----------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------
     571 | ERROR | The constant "CURL_HTTP_VERSION_2" is not present in PHP version 7.0.6 or earlier
    -----------------------------------------------------------------------------------------------------------

    Does this mean it is incompatible with all versions of PHP prior to 7.0.6? Seems to work okay…

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    well , this is not exactly a compatibility issue , but a extension missing/not-installed issue.

    LSCWP has a crawler to pre-warm the cache, the crawler uses curl , curl has support for http1.1 and http2 protocol , but in some installation , the http2 extension is not installed , and there goes your wanrning.

    Best regards,

    Thread Starter benz1

    (@benz1)

    Thanks @qtwrk, so it can safely be ignored?

    Might be worth advising WP Engine so it can be added to their whitelist at https://github.com/wpengine/phpcompat/wiki/Results.

    Thread Starter benz1

    (@benz1)

    Sorry, obviously the original message was in relation to LiteSpeed Cache, not the FB plugin 🙂

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Yes , this message can be safely ignored.

    And thanks for that advice 🙂

    Best regards,

    Thread Starter benz1

    (@benz1)

    Cool, thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP 7.0 compatibility’ is closed to new replies.