Support » Plugin: IgniteUp - Coming Soon and Maintenance Mode » PHP 7.0 compatibility?

  • Resolved wsp-kk

    (@wsp-kk)


    I just finished running the PHP Compatibility Checker on my site, and IgniteUp was the only plugin flagged with an error, as follows:

    FILE: /home/content/79/9493179/html/knc2015/wp-content/plugins/igniteup/includes/class-admin-options.php
    -------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------------------
     43 | ERROR | Function split() is deprecated since PHP 5.3 and removed since PHP 7.0; Use preg_split instead
    -------------------------------------------------------------------------------------------------------------

    Is this known to create an issue under PHP 7.0, or should I treat this as a false positive and proceed with the upgrade? Let me know.

    Thanks.

    -KK

Viewing 1 replies (of 1 total)
  • Plugin Author Ceylon Systems

    (@ceylonsystems)

    Hi @wsp-kk,

    The notice seems correct. But we are no longer using the function which is this “split()” function is being called.

    So you can proceed with the upgrade. IgniteUp will work on PHP7 without any issue.

    Also, I would like to thank you for letting us know about this.

    Thanks!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.