WordPress.org

Support

Support » Plugins and Hacks » Instapress » PHP 5.4 Errors

PHP 5.4 Errors

  • Hi,

    I just updated my server to 5.4 and noticed that your plugin has some incompatibilities – namely that there are some instances of “call-time pass-by-reference”. There is a good explanation of how the code should be updated in this Stack Exchange post – http://stackoverflow.com/questions/8971261/php-5-4-call-time-pass-by-reference-easy-fix-available

    The lines that need to be updated are:

    • /instapress/instagram.php on line 306 (getFeedByUserId reference)
    • /instapress/instagram.php on line 309 (getFeedByUserId reference)
    • /instapress/instagram.php on line 311 (getFeedByTag reference)
    • /instapress/instagram.php on line 389 (getFeedByUserId function)
    • /instapress/instagram.php on line 452 (getFeedByTag function)
    • /instapress/instagram.php on line 777 (getAccessToken reference)
    • /instapress/instagram.php on line 952 (getAccessToken function) – this doesn’t actually take an argument
    • /instapress/widget.php on line 80 (getFeedByUserId reference)
    • /instapress/widget.php on line 83 (getFeedByUserId reference)
    • /instapress/widget.php on line 85 (getFeedByTag reference)

    Thanks for all your work!

    http://wordpress.org/extend/plugins/instapress/

  • The topic ‘PHP 5.4 Errors’ is closed to new replies.
Skip to toolbar