Support » Plugin: AnythingSlider for WordPress » PHP 5.4 creates warnings (Fixable)

  • Resolved Sean Donovan

    (@mrsdonovan)


    After upgrading to PHP 5.4.11, the following problems warnings showed up:

    Warning: Illegal string offset ‘order’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 200

    Warning: Illegal string offset ‘orderby’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 201

    Warning: Illegal string offset ‘orderby’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 208

    Warning: Illegal string offset ‘order’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 209

    Warning: Illegal string offset ‘cat’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 211

    Warning: Illegal string offset ‘navformat’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 317

    Warning: Illegal string offset ‘navformat’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 317

    Warning: Illegal string offset ‘navformat’ in ***/plugins/anythingslider-for-wordpress/jtd-anything-slider.php on line 317

    With thanks to this forum post, the problem was fixed by adding “isset” around the offending points in code. The plugin seems to work find after that.

    http://wordpress.org/extend/plugins/anythingslider-for-wordpress/

Viewing 1 replies (of 1 total)
  • Just noting that it has been resolved as far as my testing shows. As an aside – our host was having problems with shared server loading and PHP 5.3 was causing 500 Internal Server Errors or page not found. In my desperation, I upgraded to PHP 5.4 and although the site is still slow, WordPress works again.

    Running WordPress 3.5.1 and PHP 5.4.11

Viewing 1 replies (of 1 total)
  • The topic ‘PHP 5.4 creates warnings (Fixable)’ is closed to new replies.