Support » Everything else WordPress » PHP 5.3 Compatibility — What's the earliest version that works?

  • Random question, I apologize.

    I’ve read through the changelogs from 2.8 +, but haven’t found anything that explicitly states “this is/is not the version that makes corrections for PHP 5.3”.

    If anybody knows, I’d be most appreciative. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    (@esmi)

    Forum Moderator

    What corrections?

    As far as I know, core WordPress wasn’t fully compatible with PHP 5.3 without revisions. The latest certainly is–but I am wondering what the earliest version that worked is.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Two years ago, some people had issues with 2.8 and 5.3, but that stemmed from bad php.ini settings with timezones. Other than some deprecation warnings, I believe the two were compatible out of the box. Same can’t be said for plugins, of course.

    I believe 3.0 was the first version to fully support 5.3, though it worked for many of us before that.

    Of course, WordPress 3.2 works great on PHP 5.3.x and no previous versions of WordPress are supported.

    Awesome, thanks a lot!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP 5.3 Compatibility — What's the earliest version that works?’ is closed to new replies.