WordPress.org

Support

Support » How-To and Troubleshooting » PHP 5.2 Fatal Error in cache.php

PHP 5.2 Fatal Error in cache.php

Viewing 9 replies - 1 through 9 (of 9 total)
  • According to a user in another forum you can re-upload the /wp-includes files and it cures it.
    ???

    No, why should that cure this issue?

    Any ideas? on that? anyone out there running wordpress using php 5.2? any other websites i could search?

    I get the same PHP error, but the fix above didn’t help at all, as I’m not good with PHP or MySQL.

    For example, it said:
    Temporary fix :
    wp-includes/cache.php Line 28:
    if (!is_object($wp_object_cache)) {
    $wp_object_cache = new WP_Object_Cache();
    }
    wp-includes/cache.php Line 187:
    if (!is_object($wpdb)) {
    $wpdb = new wpdb(DB_USER, DB_PASSWORD, DB_NAME, DB_HOST);
    }

    But it doesn’t specify if that code is supposed to REPLACE something that’s already there, or if it’s supposed to be additional to what’s there. I guessed “additional” (given that there was nothing in lines 28 or 187). I re-uploaded the cache.php file, and then the blog would not load at all.

    I’m also tracking this problem over here:

    http://wordpress.org/support/topic/96746

    Good thread to start. I’ve pondered the idea of upgrading my site to php 5.2 but was concerned if it would goof something up.

    I wonder if it would make any difference to disable the cache setting in the WordPress dashboard before doing the upgrade? I don’t know much about php upgrading, but it was just a thought that came to mind.

    Where do you disable the cache? I looked all over and didn’t see anything like that.

    And if I disable the cache, will that just break something else? (I assume the cache is there for a reason…)

    Whoa! The problem has been SOLVED!

    It was nothing I did — apparently there IS A PROBLEM WITH WORDPRESS and PHP 5.2! This problem appeared when they upgraded me to PHP 5.2 earlier in the week (I only made the connection a few minutes ago). So my host downgraded me to PHP 4 and now the blog works just fine.

    Hi blork,
    Glad to hear your problem is resolved. In regards to disabling the cache if you need to, it is here:

    Dashboard > Options > WP-Cache

    Then you can select to either disable or enable the cache. Sometimes when I’ve done changes to my template the only way I could get the change to show up right away was to disable the cache and then later go back in and re-activate it. No harm done by doing so, at least from my understanding. I don’t know if maybe the newest version of WordPress eliminated that challenge or not. I haven’t tested it since upgrading.

    I don’t know if that would have helped or not in regards to upgrading to PHP 5.2 but I think I will hold off on upgrading mine for now until more people report having success with it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PHP 5.2 Fatal Error in cache.php’ is closed to new replies.