Support » Plugin: JM Twitter Cards » PHP 5.3 is no longer supported

  • ResolvedPlugin Author jmau

    (@jmlapam)


    Hi,

    if you are using php 5.3 or less the plugin won’t work anymore. I introduced a utility that uses new syntax for array PHP and I will probably use this syntax and other features in next updates.

    php5.3 is deprecated and no longer supported and is above all very old. Please contact your webhosting and upgrade to at least php 5.4 or 5.6. Php 7.0 would be great, it’s faster, more secure, etc.

    The only thing I can do here if you cannot upgrade is providing a compat file https://pastebin.com/bhjmmrfK so you have to go to this page, download the code and replace the file utilities.php which is in /jm-twitter-cards/classes/ with this one.

    But you would have to upload the same fix everytime you want to get new updates.

    I cannot support such an old version of PHP, I won’t do that and it’s for your own safety.

    Thank you for your understanding.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I installed your pluggin having an old version of PHP and the whole site is down: http://www.josh.film

    What can I do to roll it back? what files can I modify to make the site working again?

    Found the way to solve the problem by deleting the plugin folder via FTP. You should advice of this situation with some big letters in the description of the plugin.

    Plugin Author jmau

    (@jmlapam)

    it’s written here just above :

    The only thing I can do here if you cannot upgrade is providing a compat file https://pastebin.com/bhjmmrfK so you have to go to this page, download the code and replace the file utilities.php which is in /jm-twitter-cards/classes/ with this one.

    and the PHP version is shown on the main page of the plugin :

    Requires WordPress Version:4.2
    Tested up to: 4.9.1
    Requires PHP Version:5.4

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 5.3 is no longer supported’ is closed to new replies.