WordPress.org

Support

Support » Installation » php 4.1?

php 4.1?

  • I want to upgrade to 1.5 from 1.2,but my host run php,how i do?

    “Your server is running PHP version but WordPress requires at least 4.1”

Viewing 5 replies - 1 through 5 (of 5 total)
  • Tell your host to uprade to the latest php version.

    Hey,

    Are you on a commercial webhost? If so, send them an email and ask them to upgrade to (at least) php 4.1 – the current latest version (of 4) is 4.3.11.

    If you are hosting it yourself (off your own computer) then you need to upgrade it yourself. Shout back if you are in this situation.

    Rob

    thank you very much!

    I just called my webhost provider , they telled me the host ‘s php version is 4.2, but why:

    Warning: phpversion,system() has been disabled for security reasons in /z2/bujai/public_html/blog/wp-settings.php on line 16

    Warning: phpversion,system() has been disabled for security reasons in /z2/bujai/public_html/blog/wp-settings.php on line 17
    Your server is running PHP version but WordPress requires at least 4.1

    Who is your host ?
    To disable that call seems ridiculous. I would find another host.

    Hey,

    That is really stupid, yeah.

    Really awful hack: Try commenting out (add a // to the start of each line) lines 16 and 17 of wp-settings.php (where it says if ( !(phpversion().. and the line beneath) and then continue as normal.

    This will make the error go away, but I’m unsure as to whether your host is still to restrictive to allow WordPress to run normally.

    Rob

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘php 4.1?’ is closed to new replies.
Skip to toolbar