Support » Plugin: Boxers and Swipers » Photoswipe marked as “insecure content” when site moved to SSL

  • Resolved allfadr

    (@allfadr)


    When i moved my site to https, changing all possible links from http to https, the Boxers & Swipers plugin seems to not have adapted to this change.
    I use Photoswipe on images everywhere.
    The insecure content analyzer (whynopadlock.com) shows that on pages with images there are “http” links to photoswipe:
    http://*******/wp-content/plugins/boxers-and-swipers/photoswipe/photoswipe.css

    Accordingly, the browser either disables the plugin and images fall back to default WordPress behaviour, or the reader can disable the SSL to watch images with Photoswipe.

    I tried to delete and reinstall the plugin – nothing changed.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Katsushi Kawamori

    (@katsushi-kawamori)

    Hi,

    Is your management screen SSL?

    Plugin Author Katsushi Kawamori

    (@katsushi-kawamori)

    Please fix as follows.
    I can not try because I do not have an https test environment.

    inc/BoxersAndSwipers.php
    line 254-282

    before BOXERSANDSWIPERS_PLUGIN_URL
    after plugins_url($path='boxers-and-swipers',$scheme=null)

    Thread Starter allfadr

    (@allfadr)

    I’ve changed things as you propose. Seems to be working now. The problem has disappeared. Thanks.

    Yes, my admin page is SSL, too.

    • This reply was modified 4 years, 1 month ago by allfadr.
    Plugin Author Katsushi Kawamori

    (@katsushi-kawamori)

    I will distribute the corrected version in the next version.

    Thread Starter allfadr

    (@allfadr)

    BY THE WAY!
    The plugin’s settings page in the admin dashboard still is marked as “insecure content”. It has http links. So probably a similar change must be done to the php that deals with the admin page.

    Plugin Author Katsushi Kawamori

    (@katsushi-kawamori)

    Please fix as follows.

    req/BoxersAndSwipersAdmin.php
    line 1644

    before BOXERSANDSWIPERS_PLUGIN_URL
    after plugins_url($path='boxers-and-swipers',$scheme=null)

    Additional correction when this is not good.
    line 53-58
    before BOXERSANDSWIPERS_PLUGIN_URL
    after plugins_url($path='boxers-and-swipers',$scheme=null)

    Thread Starter allfadr

    (@allfadr)

    I’ve changed line 1644 – it was still insecure.
    Then I also changed lines 53-58 – now it is secure!

    Plugin Author Katsushi Kawamori

    (@katsushi-kawamori)

    Thanks!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Photoswipe marked as “insecure content” when site moved to SSL’ is closed to new replies.