Support » Plugin: TablePress » Photos not appearing in responsive mode

  • Resolved armandoarrastia

    (@armandoarrastia)


    Hi Tobias. On the noted page, I have a table with three rows (top is header row) and three columns and one photo in each cell (total six photos) but they were not appearing well on iPhone.

    Per the instructions on this page, https://tablepress.org/extensions/responsive-tables/, I downloaded the Responsive Tables extension. When I place only the Table shortcode ([table id=9/])in the page, the photos appear on both desktop and iPhone but they run off the right side.

    When I place this code ([table id=9 responsive=flip responsive_breakpoint=all/]) in the page, the photos appear on desktop but only the table header (first row) appear on iPhone. The rest of the table (including the photos) do not appear at all. There is just a white space beneath the header row (note that if you look at this on iPhone, you’ll see a set of logos beneath that white space – these are NOT the images in the table. These images are not in a table at all.

    Any suggestions for me?

    Thank you!

    (If this works, I’ll gladly contribute to the cost of the responsive tables plugin).

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter armandoarrastia

    (@armandoarrastia)

    Actually, I changed the table settings to two columns and four row to see if it would fix the issue, but it did not. So that is the way I left the table for the time being. Just want you to know….

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your question, and sorry for the trouble.

    To be honest, I don’t think the flip mode is a good choice here. For one thing, this doesn’t work without manual adjustments due to the images (one would have to adjust column heights with CSS code). I therefore recommend using the scroll mode for this table.

    Regards,
    Tobias

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Photos not appearing in responsive mode’ is closed to new replies.