Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Photonic oddness (but it might be me)

  • Resolved Lyndka

    (@lyndka)


    I’ve just installed Photonic to let me display FlickR albums on my site (and to be honest – it’s the best solution I’ve found for ease of install, setup & go plus display) BUT there’s something odd happening…

    I don’t get all the albums from my Flickr account
    offered to add to my Photonic Gallery?

    I’ve checked the privacy on all the photo’s in the first 7 albums (they’re the ones I want to display) and they’re all set public. I only get offered the first 4 albums by Photonic – am I doing something stupid or is it an API limitation from FlickR because I’m not using a “pro” account? I’ve looked and can’t see mention of API limits in FlickR help.

    Any clever ideas?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Sayontan

    (@sayontan)

    You seem to have only these albums selected in your gallery construction. I see this in your parameters: filter=72157717157278787,72157716425719922,72157716531965026,72157711586614293, which means that you are asking Photonic to only filter for these albums. If you are using the gallery wizard, in the screen where you are asked to pick your albums, right above the thumbnails there is an option, “What do you want to show?” The default there is “Automatic all”, but you might have picked “Selected albums”.

    Thread Starter Lyndka

    (@lyndka)

    Hiya – yeah – I did wonder about that but even with the filter cleared I’m only seeing 4 albums. Like I say – weirdness ๐Ÿ™

    Plugin Author Sayontan

    (@sayontan)

    but even with the filter cleared Iโ€™m only seeing 4 albums

    I am seeing 9 albums on your page now, not 4.

    Thread Starter Lyndka

    (@lyndka)

    Yeah – me too – but they’re not the albums I want to see ๐Ÿ™

    If you look at my FlickR feed – there’s 7 albums at the top of the album list I want displayed (the last 5 currently on the page I don’t want to display there).

    my albums list on FlickR

    Plugin Author Sayontan

    (@sayontan)

    I am seeing 9 albums in your Flickr Feed (Christmas 2020, Halloween 2020, Christmas 2019, Halloween 2019, Blaze, OMGOSHigans, Profile Pics, Pictures of, me and Lynds SL pictures) and those are the same 9 that I am seeing in Photonic. These are the same 9 that show up if I make an API call as well (which is why Photonic is showing those 9).

    Thread Starter Lyndka

    (@lyndka)

    Hmmm – thanks for that – so FlickR is segregating the feed somehow even though they’re allegedly “Public” – that gives me more of a clue where to look.

    I’ve tried using “organizr” to set all the pictures in my feed “public” as apparently that can cause issues similar to this – there must be something else acting on the feed then. Thanks for taking a look

    Thread Starter Lyndka

    (@lyndka)

    OK – found where the issue is but not sure how it’s easily fixable…

    If Safesearch is turned on for a FlickR user then the Albums page for another user is filtered & some albums won’t display for that user. It’s essentially the same view as someone not registered to FlickR trying to view the album.

    Giving a direct link to an image in an album will display that image – whether logged in as a FlickR user or not. For some reason the API seems to being treated as non-registered user so it isn’t given a full list of albums.

    It’s weird behaviour because the images in the albums are set as “Safe” & “Public” unless it’s a subtle throttling ploy by Flickr.

    Thread Starter Lyndka

    (@lyndka)

    …even more bizarrely…

    Browsing my own photostream without logging in to FlickR shows images from the “hidden” albums so it’s not even FlickR security that’s being a pain! Owh joy ๐Ÿ™

    Plugin Author Sayontan

    (@sayontan)

    How many albums do you have? 9 or 12? I am a little confused because in one of your posts you said that you wanted to show the first 7 and not the last 5 (which makes me assume 12), but in other cases you are referencing hidden albums from a list of 9.

    If you have 12:

    1. Set up Flickr authentication. This is easy – just follow the steps in Photonic → Authentication.
    2. Then, in the gallery wizard, set the option for โ€œWhat do you want to show?โ€ to say โ€œSelected albumsโ€.
    3. Then pick the 7 albums that you need to show.

    If you have 9 but you want to show 7 of those and all 7 are being currently seen in the output, you don’t need authentication, but you can simply do steps 2 and 3 from the above.

    Thread Starter Lyndka

    (@lyndka)

    I have 12 albums but I don’t want to display all of them – only the first 7.

    I was just trying authentication but I get a page 404 Error when I click the permission button on Flickr

    The URL being shown in the address bar is…

    `https://www.cheese-dispensers.net/blog/wp-admin/admin.php?page=photonic-auth&provider=flickr&oauth_token=72157717970899378-1e5157281bae90f9&oauth_verifier=c7e4cfe8ef7641e7′

    and I don’t get an Auth key or the secret.

    Plugin Author Sayontan

    (@sayontan)

    You seem to have a URL that says “http”, but the URL returned by Flickr is “https”. You can try setting up SSL on your site and make it https (that is something that is managed by your host). Alternatively, when you get the return URL, in the address bar change the URL to http from https – that way you will not get the 404 error.

    Thread Starter Lyndka

    (@lyndka)

    Managed to pull the oauthtoken from the wonky URL above along with the token & plugged them in to the settings page & it seems to be working now.

    Thanks for your help ๐Ÿ™‚

    Thread Starter Lyndka

    (@lyndka)

    You can try setting up SSL on your site and make it https (that is something that is managed by your host

    Yeah – not doing that – my provider doesn’t let me use an SSL key unless I buy it from them & they don’t want peanuts.

    It might be neat if the authentication module of the plugin could detect whether SSL is in use or not & generate the appropriate callback URL? ๐Ÿ˜€

    Thank you again ๐Ÿ˜€

    Plugin Author Sayontan

    (@sayontan)

    It might be neat if the authentication module of the plugin could detect whether SSL is in use or not & generate the appropriate callback URL?

    That has been in place since authentication was introduced in 2018 – this specific flow of events is beyond my control. First, Flickr changes the URL, not Photonic. Then, once the response is back, your host’s configurations kick in, and it determines that there is no URL with https. Photonic only comes into the picture once you change the URL – up until then it is in your host’s hands. If getting SSL is not an option, you might want to configure your .htaccess to change https calls to http (most people with SSL do the reverse).

    • This reply was modified 1 month, 1 week ago by Sayontan.
    Thread Starter Lyndka

    (@lyndka)

    OK cool – thanks again and I do love the plugin, it’s a stunning piece of work – far easier to get running on a WordPress site than the other two “popular” one’s I used – congratulations on that.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.